summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_1.0.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_1.0.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_1.0.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_1.0.2.bb
new file mode 100644
index 0000000000..698dfe7704
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_1.0.2.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Filesystem events monitoring"
+DEPENDS = "${PYTHON_PN}-argh"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[sha256sum] = "376cbc2a35c0392b0fe7ff16fbc1b303fd99d4dd9911ab5581ee9d69adc88982"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-argh \
+ ${PYTHON_PN}-pathtools3 \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-requests \
+"
+
+BBCLASSEXTEND = "native nativesdk"