summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-websockets_11.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-websockets_11.0.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-websockets_11.0.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-websockets_11.0.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-websockets_11.0.2.bb
new file mode 100644
index 0000000000..1653c7716d
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-websockets_11.0.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "An implementation of the WebSocket Protocol (RFC 6455)"
+HOMEPAGE = "https://github.com/aaugustin/websockets"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=51924a6af4495b8cfaee1b1da869b6f4"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "b1a69701eb98ed83dd099de4a686dc892c413d974fa31602bc00aca7cb988ac9"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"