summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_2.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_2.2.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_2.2.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_2.2.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_2.2.2.bb
new file mode 100644
index 0000000000..d2b75048c3
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_2.2.2.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The xmlschema library is an implementation of XML Schema for Python (supports Python 3.6+)."
+HOMEPAGE = "https://github.com/sissaschool/xmlschema"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0ab20f8e337bea2e6874f372edfd12c0"
+
+SRC_URI[sha256sum] = "0caa96668807b4b51c42a0fe2b6610752bc59f069615df3e34dcfffb962973fd"
+
+PYPI_PACKAGE = "xmlschema"
+inherit pypi setuptools3
+
+DEPENDS += "\
+ ${PYTHON_PN}-elementpath-native \
+"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-elementpath \
+ ${PYTHON_PN}-modules \
+"
+
+BBCLASSEXTEND = "native nativesdk"