summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch247
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet/0001-greenlet-Drop-using-register-storage-class-keyword.patch31
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet_2.0.1.bb)5
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-Include-missing-cstdint-header.patch32
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb1
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-isort_5.12.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-isort_5.11.4.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pillow/run-ptest3
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb22
8 files changed, 307 insertions, 36 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch
new file mode 100644
index 0000000000..2a6ddd4726
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch
@@ -0,0 +1,247 @@
+From 74d8c5ecdc677a7a412c7f782fe8488a5d987333 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 5 Feb 2023 19:05:45 -0800
+Subject: [PATCH] cleanup: Drop using 'register' storage class keyword everywhere
+
+This has been dropped in c++17 and newer
+
+Upstream-Status: Submitted [https://github.com/python-greenlet/greenlet/pull/347]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/greenlet/platform/switch_alpha_unix.h | 4 ++--
+ src/greenlet/platform/switch_arm32_gcc.h | 2 +-
+ src/greenlet/platform/switch_arm32_ios.h | 2 +-
+ src/greenlet/platform/switch_csky_gcc.h | 2 +-
+ src/greenlet/platform/switch_mips_unix.h | 4 ++--
+ src/greenlet/platform/switch_ppc64_aix.h | 4 ++--
+ src/greenlet/platform/switch_ppc64_linux.h | 4 ++--
+ src/greenlet/platform/switch_ppc_aix.h | 4 ++--
+ src/greenlet/platform/switch_ppc_linux.h | 4 ++--
+ src/greenlet/platform/switch_ppc_macosx.h | 4 ++--
+ src/greenlet/platform/switch_ppc_unix.h | 4 ++--
+ src/greenlet/platform/switch_s390_unix.h | 4 ++--
+ src/greenlet/platform/switch_sparc_sun_gcc.h | 4 ++--
+ src/greenlet/platform/switch_x32_unix.h | 4 ++--
+ src/greenlet/platform/switch_x86_unix.h | 2 +-
+ 15 files changed, 26 insertions(+), 26 deletions(-)
+
+diff --git a/src/greenlet/platform/switch_alpha_unix.h b/src/greenlet/platform/switch_alpha_unix.h
+index 216619f..7e07abf 100644
+--- a/src/greenlet/platform/switch_alpha_unix.h
++++ b/src/greenlet/platform/switch_alpha_unix.h
+@@ -9,8 +9,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int ret;
+- register long *stackref, stsizediff;
++ int ret;
++ long *stackref, stsizediff;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ __asm__ volatile ("mov $30, %0" : "=r" (stackref) : );
+ {
+diff --git a/src/greenlet/platform/switch_arm32_gcc.h b/src/greenlet/platform/switch_arm32_gcc.h
+index 035d6b9..655003a 100644
+--- a/src/greenlet/platform/switch_arm32_gcc.h
++++ b/src/greenlet/platform/switch_arm32_gcc.h
+@@ -56,7 +56,7 @@ __attribute__((optimize("no-omit-frame-pointer")))
+ slp_switch(void)
+ {
+ void *fp;
+- register int *stackref, stsizediff;
++ int *stackref, stsizediff;
+ int result;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ __asm__ volatile ("mov r0," REG_FP "\n\tstr r0,%0" : "=m" (fp) : : "r0");
+diff --git a/src/greenlet/platform/switch_arm32_ios.h b/src/greenlet/platform/switch_arm32_ios.h
+index e993707..9e640e1 100644
+--- a/src/greenlet/platform/switch_arm32_ios.h
++++ b/src/greenlet/platform/switch_arm32_ios.h
+@@ -38,7 +38,7 @@ __attribute__((optimize("no-omit-frame-pointer")))
+ slp_switch(void)
+ {
+ void *fp;
+- register int *stackref, stsizediff, result;
++ int *stackref, stsizediff, result;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ __asm__ volatile ("str " REG_FP ",%0" : "=m" (fp));
+ __asm__ ("mov %0," REG_SP : "=r" (stackref));
+diff --git a/src/greenlet/platform/switch_csky_gcc.h b/src/greenlet/platform/switch_csky_gcc.h
+index 7486b94..ac469d3 100644
+--- a/src/greenlet/platform/switch_csky_gcc.h
++++ b/src/greenlet/platform/switch_csky_gcc.h
+@@ -23,7 +23,7 @@ __attribute__((optimize("no-omit-frame-pointer")))
+ #endif
+ slp_switch(void)
+ {
+- register int *stackref, stsizediff;
++ int *stackref, stsizediff;
+ int result;
+
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+diff --git a/src/greenlet/platform/switch_mips_unix.h b/src/greenlet/platform/switch_mips_unix.h
+index 1916b26..b9003e9 100644
+--- a/src/greenlet/platform/switch_mips_unix.h
++++ b/src/greenlet/platform/switch_mips_unix.h
+@@ -19,8 +19,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int err;
+- register int *stackref, stsizediff;
++ int err;
++ int *stackref, stsizediff;
+ #ifdef __mips64
+ uint64_t gpsave;
+ #endif
+diff --git a/src/greenlet/platform/switch_ppc64_aix.h b/src/greenlet/platform/switch_ppc64_aix.h
+index e07b8de..e7e0b87 100644
+--- a/src/greenlet/platform/switch_ppc64_aix.h
++++ b/src/greenlet/platform/switch_ppc64_aix.h
+@@ -74,8 +74,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int err;
+- register long *stackref, stsizediff;
++ int err;
++ long *stackref, stsizediff;
+ void * toc;
+ void * r30;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+diff --git a/src/greenlet/platform/switch_ppc64_linux.h b/src/greenlet/platform/switch_ppc64_linux.h
+index 88e6847..3c324d0 100644
+--- a/src/greenlet/platform/switch_ppc64_linux.h
++++ b/src/greenlet/platform/switch_ppc64_linux.h
+@@ -76,8 +76,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int err;
+- register long *stackref, stsizediff;
++ int err;
++ long *stackref, stsizediff;
+ void * toc;
+ void * r30;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+diff --git a/src/greenlet/platform/switch_ppc_aix.h b/src/greenlet/platform/switch_ppc_aix.h
+index c7d476f..6d93c13 100644
+--- a/src/greenlet/platform/switch_ppc_aix.h
++++ b/src/greenlet/platform/switch_ppc_aix.h
+@@ -53,8 +53,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int err;
+- register int *stackref, stsizediff;
++ int err;
++ int *stackref, stsizediff;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ __asm__ ("mr %0, 1" : "=r" (stackref) : );
+ {
+diff --git a/src/greenlet/platform/switch_ppc_linux.h b/src/greenlet/platform/switch_ppc_linux.h
+index 0a71255..e83ad70 100644
+--- a/src/greenlet/platform/switch_ppc_linux.h
++++ b/src/greenlet/platform/switch_ppc_linux.h
+@@ -49,8 +49,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int err;
+- register int *stackref, stsizediff;
++ int err;
++ int *stackref, stsizediff;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ __asm__ ("mr %0, 1" : "=r" (stackref) : );
+ {
+diff --git a/src/greenlet/platform/switch_ppc_macosx.h b/src/greenlet/platform/switch_ppc_macosx.h
+index 56e573f..d6e5a03 100644
+--- a/src/greenlet/platform/switch_ppc_macosx.h
++++ b/src/greenlet/platform/switch_ppc_macosx.h
+@@ -46,8 +46,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int err;
+- register int *stackref, stsizediff;
++ int err;
++ int *stackref, stsizediff;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ __asm__ ("; asm block 2\n\tmr %0, r1" : "=g" (stackref) : );
+ {
+diff --git a/src/greenlet/platform/switch_ppc_unix.h b/src/greenlet/platform/switch_ppc_unix.h
+index 2b3d307..ca590a5 100644
+--- a/src/greenlet/platform/switch_ppc_unix.h
++++ b/src/greenlet/platform/switch_ppc_unix.h
+@@ -47,8 +47,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int err;
+- register int *stackref, stsizediff;
++ int err;
++ int *stackref, stsizediff;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ __asm__ ("mr %0, 1" : "=g" (stackref) : );
+ {
+diff --git a/src/greenlet/platform/switch_s390_unix.h b/src/greenlet/platform/switch_s390_unix.h
+index 6641854..9199367 100644
+--- a/src/greenlet/platform/switch_s390_unix.h
++++ b/src/greenlet/platform/switch_s390_unix.h
+@@ -36,8 +36,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int ret;
+- register long *stackref, stsizediff;
++ int ret;
++ long *stackref, stsizediff;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ #ifdef __s390x__
+ __asm__ volatile ("lgr %0, 15" : "=r" (stackref) : );
+diff --git a/src/greenlet/platform/switch_sparc_sun_gcc.h b/src/greenlet/platform/switch_sparc_sun_gcc.h
+index 652b57f..96990c3 100644
+--- a/src/greenlet/platform/switch_sparc_sun_gcc.h
++++ b/src/greenlet/platform/switch_sparc_sun_gcc.h
+@@ -51,8 +51,8 @@
+ static int
+ slp_switch(void)
+ {
+- register int err;
+- register int *stackref, stsizediff;
++ int err;
++ int *stackref, stsizediff;
+
+ /* Put current stack pointer into stackref.
+ * Register spilling is done in save/restore.
+diff --git a/src/greenlet/platform/switch_x32_unix.h b/src/greenlet/platform/switch_x32_unix.h
+index cb14ec1..893369c 100644
+--- a/src/greenlet/platform/switch_x32_unix.h
++++ b/src/greenlet/platform/switch_x32_unix.h
+@@ -22,8 +22,8 @@ slp_switch(void)
+ void* ebx;
+ unsigned int csr;
+ unsigned short cw;
+- register int err;
+- register int *stackref, stsizediff;
++ int err;
++ int *stackref, stsizediff;
+ __asm__ volatile ("" : : : REGS_TO_SAVE);
+ __asm__ volatile ("fstcw %0" : "=m" (cw));
+ __asm__ volatile ("stmxcsr %0" : "=m" (csr));
+diff --git a/src/greenlet/platform/switch_x86_unix.h b/src/greenlet/platform/switch_x86_unix.h
+index 3a95186..493fa6b 100644
+--- a/src/greenlet/platform/switch_x86_unix.h
++++ b/src/greenlet/platform/switch_x86_unix.h
+@@ -51,7 +51,7 @@ slp_switch(void)
+ #endif
+ void *ebp, *ebx;
+ unsigned short cw;
+- register int *stackref, stsizediff;
++ int *stackref, stsizediff;
+ __asm__ volatile ("" : : : "esi", "edi");
+ __asm__ volatile ("fstcw %0" : "=m" (cw));
+ __asm__ volatile ("movl %%ebp, %0" : "=m" (ebp));
+--
+2.39.1
+
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet/0001-greenlet-Drop-using-register-storage-class-keyword.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet/0001-greenlet-Drop-using-register-storage-class-keyword.patch
deleted file mode 100644
index 5abe59279f..0000000000
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet/0001-greenlet-Drop-using-register-storage-class-keyword.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From aa505359a3bb5a954fe3c7fbd853c75802bf3533 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 16 Jan 2023 21:37:26 -0800
-Subject: [PATCH] greenlet: Drop using 'register' storage class keyword
-
-This has been dropped in c++17 and newer
-
-Upstream-Status: Submitted [https://github.com/python-greenlet/greenlet/pull/336]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/greenlet/platform/switch_riscv_unix.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/greenlet/platform/switch_riscv_unix.h b/src/greenlet/platform/switch_riscv_unix.h
-index 5b5ea98..24df9db 100644
---- a/src/greenlet/platform/switch_riscv_unix.h
-+++ b/src/greenlet/platform/switch_riscv_unix.h
-@@ -11,8 +11,8 @@
- static int
- slp_switch(void)
- {
-- register int ret;
-- register long *stackref, stsizediff;
-+ int ret;
-+ long *stackref, stsizediff;
- __asm__ volatile ("" : : : REGS_TO_SAVE);
- __asm__ volatile ("mv %0, sp" : "=r" (stackref) : );
- {
---
-2.39.0
-
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet_2.0.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb
index 4a50a24184..a2e036a891 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet_2.0.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb
@@ -4,8 +4,7 @@ LICENSE = "MIT & PSF-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e95668d68e4329085c7ab3535e6a7aee \
file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
-SRC_URI += "file://0001-greenlet-Drop-using-register-storage-class-keyword.patch"
-
-SRC_URI[sha256sum] = "42e602564460da0e8ee67cb6d7236363ee5e131aa15943b6670e44e5c2ed0f67"
+SRC_URI += "file://0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch"
+SRC_URI[sha256sum] = "e7c8dc13af7db097bed64a051d2dd49e9f0af495c26995c00a9ee842690d34c0"
inherit pypi setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-Include-missing-cstdint-header.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-Include-missing-cstdint-header.patch
new file mode 100644
index 0000000000..f970cf3c3c
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-Include-missing-cstdint-header.patch
@@ -0,0 +1,32 @@
+From 752e30eebe5b91c323bafcbea8d450dd5683701a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 30 Jan 2023 10:31:10 -0800
+Subject: [PATCH] Include missing <cstdint> header
+
+gcc 13 moved some includes around and as a result <cstdint> is
+no longer transitively included [1]. Explicitly include it for
+int32_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Upstream-Status: Submitted [https://code-review.googlesource.com/c/re2/+/60970]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ third_party/re2/util/pcre.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/third_party/re2/util/pcre.h b/third_party/re2/util/pcre.h
+index 896b0bd..271a005 100644
+--- a/third_party/re2/util/pcre.h
++++ b/third_party/re2/util/pcre.h
+@@ -163,6 +163,7 @@
+
+ #include "util/util.h"
+ #include "re2/stringpiece.h"
++#include <cstdint>
+
+ #ifdef USEPCRE
+ #include <pcre.h>
+--
+2.39.1
+
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb
index b0971db1cc..3d45c56b0a 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.51.1.bb
@@ -10,6 +10,7 @@ SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \
file://boring_ssl.patch \
file://mips_bigendian.patch \
+ file://0001-Include-missing-cstdint-header.patch \
file://abseil-ppc-fixes.patch;patchdir=third_party/abseil-cpp \
"
SRC_URI[sha256sum] = "e6dfc2b6567b1c261739b43d9c59d201c1b89e017afd9e684d85aa7a186c9f7a"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_5.11.4.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_5.12.0.bb
index 3ece22c382..6d7b20f3a9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_5.11.4.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_5.12.0.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
SECTION = "devel/python"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489"
-SRC_URI[sha256sum] = "6db30c5ded9815d813932c04c2f85a360bcdd35fed496f4d8f35495ef0a261b6"
+SRC_URI[sha256sum] = "8bef7dde241278824a6d83f44a544709b065191b95b6e50894bdc722fcba0504"
inherit pypi python_poetry_core
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pillow/run-ptest b/meta-openembedded/meta-python/recipes-devtools/python/python3-pillow/run-ptest
new file mode 100644
index 0000000000..3385d68939
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pillow/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
index 403a987d1e..9f1cc9eac5 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
@@ -8,10 +8,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=bc416d18f294943285560364be7cbec1"
SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
file://0001-support-cross-compiling.patch \
file://0001-explicitly-set-compile-options.patch \
+ file://run-ptest \
"
SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
-inherit setuptools3
+inherit setuptools3 ptest
PIP_INSTALL_PACKAGE = "Pillow"
PIP_INSTALL_DIST_PATH = "${S}/dist"
@@ -31,12 +32,31 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-numbers \
"
+RDEPENDS:${PN}-ptest += " \
+ bash \
+ ghostscript \
+ jpeg-tools \
+ libwebp \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-image \
+ ${PYTHON_PN}-mmap \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-pytest-timeout \
+ ${PYTHON_PN}-resource \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \
+"
+
CVE_PRODUCT = "pillow"
S = "${WORKDIR}/git"
RPROVIDES:${PN} += "python3-imaging"
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/Tests
+ cp -rf ${S}/Tests ${D}${PTEST_PATH}/
+}
+
BBCLASSEXTEND = "native"
SRCREV = "a5bbab1c1e63b439de191ef2040173713b26d2da"