summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb)18
3 files changed, 9 insertions, 13 deletions
diff --git a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch
index f613fdce4d..0498f3ddd0 100644
--- a/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch
+++ b/meta-openembedded/meta-python/recipes-connectivity/telepathy/telepathy-python3-0.15.19/telepathy-python_fix_for_automake_1.12.patch
@@ -9,7 +9,7 @@ of warning-errors.
| make[1]: Leaving directory `/srv/home/nitin/builds2/build0/tmp/work/i586-poky-linux/telepathy-python-0.15.19-r4/telepathy-python-0.15.19/src'
| make: *** [all-recursive] Error 1
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
2012/07/10
Index: telepathy-python-0.15.19/src/Makefile.am
===================================================================
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index f4c74384f9..85423a3fec 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -5,7 +5,7 @@ Subject: [PATCH] setup.py: link in sysroot, not in host directories
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-Upstream-status: Unknown
+Upstream-Status: Unknown
---
setup.py | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
index 66aefac3d6..bb604982d0 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
@@ -5,16 +5,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
DEPENDS = "boost"
-SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
- file://0001-Do-not-strip-binaries.patch \
-"
+SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https"
-SRCREV = "aa304c9c7d725ffb9d10af08a3b34cb372307020"
+SRCREV = "0bd8896a4010f2d91b2340570c24fa08606ec406"
S = "${WORKDIR}/git"
-BBCLASSEXTEND = "native"
-
EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
inherit cmake setuptools3 python3native
@@ -23,17 +19,17 @@ PIP_INSTALL_DIST_PATH = "${S}/dist"
PIP_INSTALL_PACKAGE = "pybind11"
do_configure() {
- cmake_do_configure
+ cmake_do_configure
}
do_compile() {
- setuptools3_do_compile
- cmake_do_compile
+ setuptools3_do_compile
+ cmake_do_compile
}
do_install() {
- setuptools3_do_install
- cmake_do_install
+ setuptools3_do_install
+ cmake_do_install
}
BBCLASSEXTEND = "native nativesdk"