summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-xfce/recipes-panel-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-xfce/recipes-panel-plugins')
-rw-r--r--meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch6
-rw-r--r--meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch26
-rw-r--r--meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.2.bb (renamed from meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb)4
-rw-r--r--meta-openembedded/meta-xfce/recipes-panel-plugins/mailwatch/xfce4-mailwatch-plugin_1.3.0.bb (renamed from meta-openembedded/meta-xfce/recipes-panel-plugins/mailwatch/xfce4-mailwatch-plugin_1.2.0.bb)5
-rw-r--r--meta-openembedded/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.10.2.bb (renamed from meta-openembedded/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.10.1.bb)3
5 files changed, 25 insertions, 19 deletions
diff --git a/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch b/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch
index 92a6e8384d..ae8bc5279d 100644
--- a/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch
+++ b/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch
@@ -18,6 +18,7 @@ Upstream-Status: Submitted [1]
[1] https://bugzilla.xfce.org/attachment.cgi?id=8492
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+
---
panel-plugin/xfce4-cpufreq-configure.c | 4 ++++
panel-plugin/xfce4-cpufreq-plugin.c | 13 +++++++++++--
@@ -109,13 +110,12 @@ index a6895e4..6338698 100644
+++ b/panel-plugin/xfce4-cpufreq-plugin.h
@@ -95,6 +95,8 @@ typedef struct
- CpuFreqPlugin *cpuFreq;
+ extern CpuFreqPlugin *cpuFreq;
+GtkCssProvider *currentProvider;
+
G_BEGIN_DECLS
void
---
+---
2.20.1
-
diff --git a/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch b/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch
index d5238d00ff..95605f83ae 100644
--- a/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch
+++ b/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch
@@ -5,26 +5,34 @@ Part of Patch from https://src.fedoraproject.org/rpms/xfce4-cpufreq-plugin/raw/m
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Refresh for xfce4-cpufreq-plugin 1.2.2.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+---
+ panel-plugin/xfce4-cpufreq-plugin.c | 1 +
+ panel-plugin/xfce4-cpufreq-plugin.h | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/panel-plugin/xfce4-cpufreq-plugin.c b/panel-plugin/xfce4-cpufreq-plugin.c
+index 1e33492..ce9e302 100644
--- a/panel-plugin/xfce4-cpufreq-plugin.c
+++ b/panel-plugin/xfce4-cpufreq-plugin.c
-@@ -37,7 +37,8 @@
- #include "xfce4-cpufreq-linux.h"
+@@ -38,6 +38,7 @@
#endif /* __linux__ */
--
-+CpuFreqPlugin *cpuFreq;
+ CpuFreqPlugin *cpuFreq;
+GtkCssProvider *currentProvider;
void
cpufreq_label_set_font (void)
+diff --git a/panel-plugin/xfce4-cpufreq-plugin.h b/panel-plugin/xfce4-cpufreq-plugin.h
+index 8cd0d33..7dbccef 100644
--- a/panel-plugin/xfce4-cpufreq-plugin.h
+++ b/panel-plugin/xfce4-cpufreq-plugin.h
-@@ -93,9 +93,9 @@ typedef struct
- gint timeoutHandle;
- } CpuFreqPlugin;
+@@ -95,7 +95,7 @@ typedef struct
--CpuFreqPlugin *cpuFreq;
-+extern CpuFreqPlugin *cpuFreq;
+ extern CpuFreqPlugin *cpuFreq;
-GtkCssProvider *currentProvider;
+extern GtkCssProvider *currentProvider;
diff --git a/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb b/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.2.bb
index 5dce51b925..3b7b9ec5da 100644
--- a/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb
+++ b/meta-openembedded/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.2.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1f6f1c0be32491a0c8d2915607a28f36"
inherit xfce-panel-plugin
-SRC_URI[md5sum] = "ccd8f0f7aef51bc4caf1049986d9614f"
-SRC_URI[sha256sum] = "c5e044c0dc401d2066f208a3df82a588b3e51ff01425f155d0a1d0f8fce8f5b5"
+SRC_URI[sha256sum] = "500f04b8d857c96da8c8c7a4eecba30a903d0fce6e35a05e674529e43b47e498"
+
SRC_URI += "file://0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch \
file://xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch \
"
diff --git a/meta-openembedded/meta-xfce/recipes-panel-plugins/mailwatch/xfce4-mailwatch-plugin_1.2.0.bb b/meta-openembedded/meta-xfce/recipes-panel-plugins/mailwatch/xfce4-mailwatch-plugin_1.3.0.bb
index c8224148ba..c4172f4d6b 100644
--- a/meta-openembedded/meta-xfce/recipes-panel-plugins/mailwatch/xfce4-mailwatch-plugin_1.2.0.bb
+++ b/meta-openembedded/meta-xfce/recipes-panel-plugins/mailwatch/xfce4-mailwatch-plugin_1.3.0.bb
@@ -5,10 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
inherit xfce-panel-plugin
-DEPENDS += "gnutls libgcrypt"
+DEPENDS += "gnutls"
-SRC_URI[md5sum] = "7263114ec0f2987a3aff15afeeb45577"
-SRC_URI[sha256sum] = "624acc8229a8593c0dfeb28f883f4958119a715cc81cecdbaf29efc8ab1edcad"
+SRC_URI[sha256sum] = "20f91ebefd2880b27f421f773115b3740f67de2bf60feace3841bfd1a09cbe2e"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
diff --git a/meta-openembedded/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.10.1.bb b/meta-openembedded/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.10.2.bb
index ad9b6e9e74..4045230198 100644
--- a/meta-openembedded/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.10.1.bb
+++ b/meta-openembedded/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.10.2.bb
@@ -7,7 +7,6 @@ inherit xfce-panel-plugin
DEPENDS += "libsoup-2.4 dbus-glib upower"
-SRC_URI[md5sum] = "203ad16e74d4823f6fb6e9a18bb7df55"
-SRC_URI[sha256sum] = "afb2af5f3effc2ea6181636ed0e82e6dafd556ec1b8478100802f85a5d167a89"
+SRC_URI[sha256sum] = "9017790b92953090c849b17b357b42fa8c562bf0e25af2fd2e5f53cfebc662c6"
FILES_${PN} += "${datadir}/xfce4/weather"