summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.16.0.bb')
-rw-r--r--meta-openembedded/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.16.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openembedded/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.16.0.bb b/meta-openembedded/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.16.0.bb
new file mode 100644
index 0000000000..7a269ad666
--- /dev/null
+++ b/meta-openembedded/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.16.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Xfce4 Widget library and X Window System interaction"
+SECTION = "x11/libs"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475"
+DEPENDS = "intltool-native perl-native gtk+3 libice libsm libxfce4util xfce4-dev-tools xfconf virtual/libx11"
+
+inherit xfce gtk-doc gobject-introspection features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+# TODO: Check if this can go
+SRC_URI += "file://0001-libxfce4kbd-private-xfce4-keyboard-shortcuts.xml-fix.patch"
+SRC_URI[sha256sum] = "8b06c9e94f4be88a9d87c47592411b6cbc32073e7af9cbd64c7b2924ec90ceaa"
+
+EXTRA_OECONF += "--with-vendor-info=${DISTRO}"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gladeui2] = "--enable-gladeui2,--disable-gladeui2,glade"
+PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
+
+PACKAGES += "${PN}-glade"
+FILES_${PN}-glade = " \
+ ${libdir}/glade \
+ ${datadir}/glade \
+"