summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-bsp')
-rw-r--r--meta-openpower/recipes-bsp/ekb/ekb.inc23
-rw-r--r--meta-openpower/recipes-bsp/ekb/ekb_git.bb25
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/ekb/ekb.inc b/meta-openpower/recipes-bsp/ekb/ekb.inc
new file mode 100644
index 0000000000..268a55dd56
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ekb/ekb.inc
@@ -0,0 +1,23 @@
+EKB_BRANCH = "main-p10"
+EKB_URI = "git://git@github.com/open-power/pub-ekb;branch=${EKB_BRANCH}"
+EKB_REV = "52e5c0038a50cc641dffdc6158f8c21930c70678"
+
+REQ_ATTRS_XMLS = "hwpf/fapi2/xml/attribute_info/chip_attributes.xml \
+ hwpf/fapi2/xml/attribute_info/common_attributes.xml \
+ hwpf/fapi2/xml/attribute_info/scratch_attributes.xml \
+ hwpf/fapi2/xml/attribute_info/system_attributes.xml \
+ hwpf/fapi2/xml/attribute_info/unit_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_bars_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_chip_ec_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_clock_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_freq_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_hcode_image_build_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_ipl_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_ipl_customize_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_memory_bars_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_nest_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_pervasive_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_qme_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_runn_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_sbe_load_bootloader_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_sbe_attributes.xml"
diff --git a/meta-openpower/recipes-bsp/ekb/ekb_git.bb b/meta-openpower/recipes-bsp/ekb/ekb_git.bb
new file mode 100644
index 0000000000..4ecf1f8d33
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ekb/ekb_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "To get required hardware procedure attribute xml files"
+DESCRIPTION = "Copy all the required hardware procedures attributes xml file \
+with respective directory structures"
+
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE_PROLOG;md5=d8e5f403c98fd80dcea90b9cc8cd083c"
+
+require ekb.inc
+
+SRC_URI = "${EKB_URI}"
+SRCREV = "${EKB_REV}"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+do_install() {
+
+ mkdir -p ${D}${datadir}/${BPN}
+
+ # Copying all required hwp's attributes xml file with respective directory structures
+ (cd ${S} && cp --parents ${REQ_ATTRS_XMLS} ${D}${datadir}/${BPN})
+}