summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/host')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb8
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb3
2 files changed, 10 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 8dce7b0e61..50c9baf9dd 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -86,6 +86,11 @@ pkg_postinst:${PN}() {
ln -s $TARGET $LINK
LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
ln -s $TARGET $LINK
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
+ TARGET="../op-clock-data-logger@.service"
+ ln -s $TARGET $LINK
fi
# If the memory preserving reboot feature is enabled, set it up
@@ -147,6 +152,9 @@ pkg_prerm:${PN}() {
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
+ rm $LINK
fi
# Remove mpreboot specific units if enabled
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 0472d2cdf4..966e4f7733 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit meson obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
-SRCREV = "ed7fb7aee34661d65dc0455316e68d90a36d75fb"
+SRCREV = "1af14431aab1193c2ec636989aa7db7ef283c8b7"
DEPENDS += " \
phosphor-logging \
@@ -52,4 +52,5 @@ SYSTEMD_SERVICE:${PN} += " \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'phal-create-boottime-guard-indicator.service', '', d)} \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'op-clear-sys-dump-active@.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'op-clock-data-logger@.service', '', d)} \
"