summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/inventory-upload
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/inventory-upload')
-rw-r--r--meta-openpower/recipes-phosphor/inventory-upload/inventory-upload.bb31
-rw-r--r--meta-openpower/recipes-phosphor/inventory-upload/inventory-upload/op-inventory-upload@.service16
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/inventory-upload/inventory-upload.bb b/meta-openpower/recipes-phosphor/inventory-upload/inventory-upload.bb
new file mode 100644
index 0000000000..8dcd48973a
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/inventory-upload/inventory-upload.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Inventory upload"
+DESCRIPTION = "Inventory upload."
+HOMEPAGE = "http://github.com/openbmc/openpower-inventory-upload"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit allarch
+inherit setuptools
+inherit obmc-phosphor-systemd
+
+RDEPENDS_${PN} += " \
+ python-dbus \
+ python-pygobject \
+ pyphosphor \
+ dtc \
+ "
+
+SRC_URI += "git://github.com/openbmc/openpower-inventory-upload"
+
+SRCREV = "c115852fb5aa0890373d8c2dfca9b9f7b1e06527"
+
+S = "${WORKDIR}/git"
+
+TMPL = "op-inventory-upload@.service"
+INSTFMT = "op-inventory-upload@{0}.service"
+TGTFMT = "obmc-host-start@{0}.target"
+FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/inventory-upload/inventory-upload/op-inventory-upload@.service b/meta-openpower/recipes-phosphor/inventory-upload/inventory-upload/op-inventory-upload@.service
new file mode 100644
index 0000000000..022f6e73e9
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/inventory-upload/inventory-upload/op-inventory-upload@.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Inventory Upload
+Wants=obmc-host-start-pre@%i.target
+Before=obmc-host-start-pre@%i.target
+Conflicts=obmc-host-stop@%i.target
+
+[Service]
+Restart=no
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/usr/bin/env inventory_upload.py
+SyslogIdentifier=inventory_upload.py
+Environment="PYTHONUNBUFFERED=1"
+
+[Install]
+WantedBy=obmc-host-start@%i.target