summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb')
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb b/meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb
new file mode 100644
index 0000000000..0fd040d418
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Init BMC MAC address"
+DESCRIPTION = "Setup BMC MAC address read from VPD"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch systemd
+
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
+
+SYSTEMD_SERVICE_${PN} = "first-boot-set-mac@.service"
+
+SRC_URI = "file://${PN}.sh file://${PN}@.service"
+
+S = "${WORKDIR}"
+do_install() {
+ install -d ${D}${bindir} ${D}${systemd_system_unitdir}
+ install ${PN}.sh ${D}${bindir}/
+ install -m 644 ${PN}@.service ${D}${systemd_system_unitdir}/
+}