summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile')
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile
new file mode 100644
index 0000000000..b8f103da85
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile
@@ -0,0 +1,15 @@
+EXE = obmc-phosphor-fand
+OBJS = $(EXE).o
+DEPPKGS = gio-unix-2.0 glib-2.0
+CC = $(CROSS_COMPILE)gcc
+INCLUDES += $(shell pkg-config --cflags $(DEPPKGS))
+LIBS += $(shell pkg-config --libs $(DEPPKGS))
+
+%.o : %.c
+ $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@
+$(EXE): $(OBJS)
+ $(CC) $(LDFLAGS) $(LIBS) $^ -o $@
+clean:
+ rm -f $(OBJS) $(EXE) *.o *.d
+distclean: clean
+ rm -f *.c~ *.h~ *.sh~ Makefile~ config.mk~