summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files')
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile15
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/obmc-phosphor-fand.c29
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/obmc-phosphor-fand.service8
3 files changed, 52 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile
new file mode 100644
index 0000000000..b8f103da85
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile
@@ -0,0 +1,15 @@
+EXE = obmc-phosphor-fand
+OBJS = $(EXE).o
+DEPPKGS = gio-unix-2.0 glib-2.0
+CC = $(CROSS_COMPILE)gcc
+INCLUDES += $(shell pkg-config --cflags $(DEPPKGS))
+LIBS += $(shell pkg-config --libs $(DEPPKGS))
+
+%.o : %.c
+ $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@
+$(EXE): $(OBJS)
+ $(CC) $(LDFLAGS) $(LIBS) $^ -o $@
+clean:
+ rm -f $(OBJS) $(EXE) *.o *.d
+distclean: clean
+ rm -f *.c~ *.h~ *.sh~ Makefile~ config.mk~
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/obmc-phosphor-fand.c b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/obmc-phosphor-fand.c
new file mode 100644
index 0000000000..558ba10bcb
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/obmc-phosphor-fand.c
@@ -0,0 +1,29 @@
+/* Contributors Listed Below - COPYRIGHT 2015 */
+/* [+] International Business Machines Corp. */
+/* */
+/* */
+/* Licensed under the Apache License, Version 2.0 (the "License"); */
+/* you may not use this file except in compliance with the License. */
+/* You may obtain a copy of the License at */
+/* */
+/* http://www.apache.org/licenses/LICENSE-2.0 */
+/* */
+/* Unless required by applicable law or agreed to in writing, software */
+/* distributed under the License is distributed on an "AS IS" BASIS, */
+/* WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or */
+/* implied. See the License for the specific language governing */
+/* permissions and limitations under the License. */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <gio/gio.h>
+
+int main(int argc, char *argv[])
+{
+ printf("obmc-phosphor-fand starting...\n");
+
+ while(1)
+ sleep(5);
+
+ exit(EXIT_SUCCESS);
+}
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/obmc-phosphor-fand.service b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/obmc-phosphor-fand.service
new file mode 100644
index 0000000000..0dc2b026a8
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/obmc-phosphor-fand.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Phosphor OpenBMC fan management daemon
+
+[Service]
+ExecStart=/usr/sbin/obmc-phosphor-fand
+
+[Install]
+WantedBy=multi-user.target