summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash')
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/files/obmc-phosphor-flashd.py29
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/files/obmc-phosphor-flashd.service8
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-phosphor-flashd.bb6
3 files changed, 43 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/files/obmc-phosphor-flashd.py b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/files/obmc-phosphor-flashd.py
new file mode 100644
index 0000000000..5e5dd8f36e
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/files/obmc-phosphor-flashd.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python
+
+# Contributors Listed Below - COPYRIGHT 2015
+# [+] International Business Machines Corp.
+#
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied. See the License for the specific language governing
+# permissions and limitations under the License.
+
+import time
+import sys
+import dbus
+import dbus.service
+import dbus.mainloop.glib
+
+if __name__ == '__main__':
+ print "obmc-phosphor-flashd starting..."
+
+ while 1:
+ time.sleep(5)
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/files/obmc-phosphor-flashd.service b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/files/obmc-phosphor-flashd.service
new file mode 100644
index 0000000000..2f518f3688
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/files/obmc-phosphor-flashd.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Phosphor OpenBMC flash management daemon
+
+[Service]
+ExecStart=/usr/sbin/obmc-phosphor-flashd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-phosphor-flashd.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-phosphor-flashd.bb
new file mode 100644
index 0000000000..822101963a
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-flash/obmc-phosphor-flashd.bb
@@ -0,0 +1,6 @@
+SUMMARY = "Phosphor OpenBMC Flash Management"
+DESCRIPTION = "Phosphor OpenBMC flash management reference implementation."
+PR = "r1"
+
+inherit obmc-phosphor-flash-mgmt
+inherit obmc-phosphor-py-daemon