summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/obmc-phosphor-qemu/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/obmc-phosphor-qemu/files/Makefile')
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-qemu/files/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-qemu/files/Makefile b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-qemu/files/Makefile
new file mode 100644
index 0000000000..6517af089d
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-qemu/files/Makefile
@@ -0,0 +1,15 @@
+EXE = obmc-phosphor-qemu
+OBJS = $(EXE).o
+PACKAGES= gio-unix-2.0 glib-2.0
+INCLUDES += $(shell pkg-config --cflags $(PACKAGES))
+LIBS += $(shell pkg-config --libs $(PACKAGES))
+CC = $(CROSS_COMPILE)gcc
+
+%.o : %.c
+ $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@
+$(EXE): $(OBJS)
+ $(CC) $(LDFLAGS) $(LIBS) $^ -o $@
+clean:
+ rm -f $(OBJS) $(EXE) *.o *.d
+distclean: clean
+ rm -f *.c~ *.h~ *.sh~ Makefile~ config.mk~