summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools/python/python3_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-devtools/python/python3_%.bbappend')
-rw-r--r--meta-phosphor/recipes-devtools/python/python3_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python3_%.bbappend b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
index f689a9e91b..5d5e38a7bc 100644
--- a/meta-phosphor/recipes-devtools/python/python3_%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
@@ -3,3 +3,9 @@ inherit update-alternatives
ALTERNATIVE_${PN}-core += "python"
ALTERNATIVE_LINK_NAME[python] = "${bindir}/python"
ALTERNATIVE_TARGET[python] = "${bindir}/python3"
+
+# Even though python3 is built with --without-ensurepip, it still installs
+# a large, compressed version of pip. Remove it to free up the space.
+do_install_append_class-target() {
+ rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip
+}