summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb19
1 files changed, 9 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index d0443d1ce6..f682b62c95 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -1,12 +1,5 @@
SUMMARY = "sdbus++ dbus API / binding generator"
DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
-
-PYPI_PACKAGE = "sdbusplus"
-PV = "1.0"
-inherit setuptools3
-
-include sdbusplus-rev.inc
-
## The sdbusplus repository has an Apache LICENSE file, which we would
## normally check here, but the python setup script is in a subdirectory
## which requires us to set ${S} below. When we change ${S} from the root
@@ -14,14 +7,18 @@ include sdbusplus-rev.inc
## to the common Apache license file in poky's meta instead.
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-S="${WORKDIR}/git/tools"
-
DEPENDS += " \
${PYTHON_PN}-inflection-native \
${PYTHON_PN}-mako-native \
${PYTHON_PN}-pyyaml-native \
"
+PV = "1.0"
+
+PYPI_PACKAGE = "sdbusplus"
+
+S = "${WORKDIR}/git/tools"
+
+inherit setuptools3
RDEPENDS:${PN} += " \
${PYTHON_PN}-inflection \
@@ -29,4 +26,6 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-pyyaml \
"
+include sdbusplus-rev.inc
+
BBCLASSEXTEND += "native nativesdk"