summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended/stdplus/stdplus_git.bb')
-rw-r--r--meta-phosphor/recipes-extended/stdplus/stdplus_git.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
index 8308dc1d27..2714e36648 100644
--- a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
+++ b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
@@ -1,22 +1,21 @@
SUMMARY = "Common C++ functions"
DESCRIPTION = "Common C++ functions."
HOMEPAGE = "http://github.com/openbmc/stdplus"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-inherit meson pkgconfig
-
DEPENDS += " \
fmt \
liburing \
"
+SRCREV = "aa4fcfc208c45511aa9788a08c969425e440fda0"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
-PACKAGES =+ "libstdplus libstdplus-dl libstdplus-io_uring"
-FILES:libstdplus = "${libdir}/libstdplus.so.*"
-FILES:libstdplus-dl = "${libdir}/libstdplus-dl.so.*"
-FILES:libstdplus-io_uring = "${libdir}/libstdplus-io_uring.so.*"
+SRC_URI += "git://github.com/openbmc/stdplus;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig
EXTRA_OEMESON = " \
-Dexamples=false \
@@ -24,7 +23,8 @@ EXTRA_OEMESON = " \
-Dgtest=disabled \
"
-SRC_URI += "git://github.com/openbmc/stdplus;branch=master;protocol=https"
-SRCREV = "aa4fcfc208c45511aa9788a08c969425e440fda0"
+PACKAGES =+ "libstdplus libstdplus-dl libstdplus-io_uring"
-S = "${WORKDIR}/git"
+FILES:libstdplus = "${libdir}/libstdplus.so.*"
+FILES:libstdplus-dl = "${libdir}/libstdplus-dl.so.*"
+FILES:libstdplus-io_uring = "${libdir}/libstdplus-io_uring.so.*"