summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/console/obmc-console_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/console/obmc-console_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
new file mode 100644
index 0000000000..d4d6e616c7
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -0,0 +1,37 @@
+SUMMARY = "OpenBMC console daemon"
+DESCRIPTION = "Daemon to handle UART console connections"
+HOMEPAGE = "http://github.com/openbmc/obmc-console"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+inherit autotools
+inherit obmc-phosphor-discovery-service
+
+TARGET_CFLAGS += "-fpic -O2"
+
+DEPENDS += "autoconf-archive-native"
+
+SRC_URI += "git://github.com/openbmc/obmc-console"
+SRC_URI += "file://${PN}.conf"
+
+SRCREV = "3c89b263484128071343bdaf0b5f3a8dace32799"
+PV = "1.0+git${SRCPV}"
+
+REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
+OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
+SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
+SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
+
+SYSTEMD_SERVICE_${PN} = " \
+ ${PN}@.service \
+ ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
+ ${PN}-ssh.socket \
+ ${PN}-ssh@.service \
+ "
+do_install_append() {
+ install -m 0755 -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
+}
+
+S = "${WORKDIR}/git"