summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb b/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
new file mode 100644
index 0000000000..8290ecce20
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dbus/dbus-perms.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Phosphor OpenBMC DBUS Permissions"
+DESCRIPTION = "Phosphor OpenBMC DBUS Permissions."
+HOMEPAGE = "http://github.com/openbmc/"
+PR = "r1"
+
+inherit allarch
+inherit obmc-phosphor-license
+inherit dbus-dir
+
+SRC_URI += "file://org.openbmc.conf"
+
+do_install_append() {
+ install -d ${D}${dbus_system_confdir}
+ install -m 0644 ${WORKDIR}/org.openbmc.conf \
+ ${D}${dbus_system_confdir}
+}