summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb16
1 files changed, 13 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 658843ba6a..835abaf283 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -6,16 +6,26 @@ S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit autotools pkgconfig
-inherit python3native
+inherit meson
+inherit obmc-phosphor-utils
inherit phosphor-dbus-yaml
+inherit python3native
DEPENDS += " \
${PYTHON_PN}-sdbus++-native \
- autoconf-archive-native \
sdbusplus \
systemd \
"
SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces"
SRCREV = "11699d678d4166ff4b23900f31794754f305df64"
+
+# Process OBMC_ORG_YAML_SUBDIRS to create Meson config options.
+# ex. xyz/openbmc_project -> -Ddata_xyz_openbmc_project=true
+def pdi_meson_config(d):
+ return ' '.join([
+ '-Ddata_' + x.replace('/', '_') + '=true' \
+ for x in listvar_to_list(d, 'OBMC_ORG_YAML_SUBDIRS')
+ ])
+
+EXTRA_OEMESON_append = " ${@pdi_meson_config(d)}"