summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/obmc-control-fan.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/obmc-control-fan.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/obmc-control-fan.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/obmc-control-fan.bb b/meta-phosphor/recipes-phosphor/fans/obmc-control-fan.bb
new file mode 100644
index 0000000000..60bc876160
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/fans/obmc-control-fan.bb
@@ -0,0 +1,13 @@
+SUMMARY = "OpenBMC fan control"
+DESCRIPTION = "OpenBMC fan control."
+PR = "r1"
+
+inherit skeleton-sdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+RDEPENDS_${PN} += "libsystemd"
+SKELETON_DIR = "fanctl"
+
+DBUS_SERVICE_${PN} += "org.openbmc.control.Fans.service"
+SYSTEMD_SERVICE_${PN} += "obmc-max-fans.service"