summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb38
1 files changed, 16 insertions, 22 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
index b521d3209c..10fb5d8d87 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -1,25 +1,12 @@
+# Each platform will need a service file that starts
+# at an appropriate time per system. For instance, if
+# your system relies on passive dbus for fans or other
+# sensors then it may be prudent to wait for all of them.
SUMMARY = "Phosphor PID Fan Control"
DESCRIPTION = "Fan Control"
HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-inherit autotools pkgconfig
-
-inherit obmc-phosphor-ipmiprovider-symlink
-inherit systemd
-
-S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/phosphor-pid-control;branch=master;protocol=https"
-SRCREV = "bcdeb83ca05ed0fa352290ec8f78bb28a2d1d2fb"
-
-# Each platform will need a service file that starts
-# at an appropriate time per system. For instance, if
-# your system relies on passive dbus for fans or other
-# sensors then it may be prudent to wait for all of them.
-
DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbusplus"
DEPENDS += "phosphor-dbus-interfaces"
@@ -28,21 +15,29 @@ DEPENDS += "libevdev"
DEPENDS += "nlohmann-json"
DEPENDS += "cli11"
DEPENDS += "boost"
-
# We depend on this to be built first so we can build our providers.
DEPENDS += "phosphor-ipmi-host"
+SRCREV = "bcdeb83ca05ed0fa352290ec8f78bb28a2d1d2fb"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
+SRC_URI = "git://github.com/openbmc/phosphor-pid-control;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
SERVICE_FILE = "phosphor-pid-control.service"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE:${PN} = "${SERVICE_FILE}"
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+inherit systemd
+
EXTRA_OECONF = " \
SYSTEMD_TARGET="multi-user.target" \
--disable-tests \
"
FILES:${PN} = "${bindir}/swampd ${bindir}/setsensor"
-
# The following installs the OEM IPMI handler for the fan controls.
FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
@@ -50,8 +45,7 @@ FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"
-
-config_datadir="${datadir}/swampd/"
+config_datadir = "${datadir}/swampd/"
# config_path is the location swampd expects to find a json configuration.
# the file is expected to be named config.json
-config_path="${config_datadir}config.json"
+config_path = "${config_datadir}config.json"