summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/flash/obmc-flash-bios.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/flash/obmc-flash-bios.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/flash/obmc-flash-bios.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/flash/obmc-flash-bios.bb b/meta-phosphor/recipes-phosphor/flash/obmc-flash-bios.bb
new file mode 100644
index 0000000000..f42bef443e
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/flash/obmc-flash-bios.bb
@@ -0,0 +1,13 @@
+SUMMARY = "OpenBMC org.openbmc.Flash example implementation"
+DESCRIPTION = "A sample implementation for the org.openbmc.Flash DBUS API. \
+org.openbmc.Flash provides APIs for functions like BIOS flash access control \
+and updating."
+PR = "r1"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+SKELETON_DIR = "flashbios"
+DBUS_SERVICE_${PN} += "org.openbmc.control.Flash.service"
+SYSTEMD_SERVICE_${PN} += "obmc-flash-init.service"