summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/flash/phosphor-image-signing.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/flash/phosphor-image-signing.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/flash/phosphor-image-signing.bb30
1 files changed, 13 insertions, 17 deletions
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-image-signing.bb b/meta-phosphor/recipes-phosphor/flash/phosphor-image-signing.bb
index d10eceffa0..cfacfbe65e 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-image-signing.bb
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-image-signing.bb
@@ -1,30 +1,26 @@
SUMMARY = "OpenBMC image signing public key"
DESCRIPTION = "Public key information to be included in images for image verification."
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit allarch
-
-INSECURE_KEY = "${@'${SIGNING_KEY}' == '${STAGING_DIR_NATIVE}${datadir}/OpenBMC.priv'}"
-
DEPENDS += "openssl-native"
DEPENDS += "${@oe.utils.conditional('INSECURE_KEY', 'True', 'phosphor-insecure-signing-key-native', '', d)}"
-
-FILES:${PN} += "${sysconfdir}/activationdata/"
+PR = "r1"
SIGNING_KEY ?= "${STAGING_DIR_NATIVE}${datadir}/OpenBMC.priv"
SIGNING_KEY_TYPE = "${@os.path.splitext(os.path.basename('${SIGNING_KEY}'))[0]}"
+SYSROOT_DIRS:append = " ${sysconfdir}"
-do_install() {
- openssl pkey -in "${SIGNING_KEY}" -pubout -out ${WORKDIR}/publickey
- echo HashType=RSA-SHA256 > "${WORKDIR}/hashfunc"
-
- idir="${D}${sysconfdir}/activationdata/${SIGNING_KEY_TYPE}"
+inherit allarch
- install -d ${idir}
- install -m 644 ${WORKDIR}/publickey ${idir}
- install -m 644 ${WORKDIR}/hashfunc ${idir}
+do_install() {
+ openssl pkey -in "${SIGNING_KEY}" -pubout -out ${WORKDIR}/publickey
+ echo HashType=RSA-SHA256 > "${WORKDIR}/hashfunc"
+ idir="${D}${sysconfdir}/activationdata/${SIGNING_KEY_TYPE}"
+ install -d ${idir}
+ install -m 644 ${WORKDIR}/publickey ${idir}
+ install -m 644 ${WORKDIR}/hashfunc ${idir}
}
-SYSROOT_DIRS:append = " ${sysconfdir}"
+FILES:${PN} += "${sysconfdir}/activationdata/"
+
+INSECURE_KEY = "${@'${SIGNING_KEY}' == '${STAGING_DIR_NATIVE}${datadir}/OpenBMC.priv'}"