summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb b/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
index eb8e39cd06..83f52d4dae 100644
--- a/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
+++ b/meta-phosphor/recipes-phosphor/preinit-mounts/preinit-mounts.bb
@@ -1,24 +1,24 @@
-inherit allarch
-inherit update-alternatives
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_base-utils}"
-
SRC_URI += "file://init"
-FILES:${PN} += "${base_sbindir}/init"
+inherit allarch
+inherit update-alternatives
do_install() {
- install -d ${D}/${base_sbindir}
- install -m 0755 ${WORKDIR}/init ${D}/${base_sbindir}/preinit-mounts
+ install -d ${D}/${base_sbindir}
+ install -m 0755 ${WORKDIR}/init ${D}/${base_sbindir}/preinit-mounts
}
-ALTERNATIVE:${PN} = "init"
-ALTERNATIVE_TARGET[init] = "${base_sbindir}/preinit-mounts"
-ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"
+RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_base-utils}"
+
+FILES:${PN} += "${base_sbindir}/init"
+ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"
# Use a number higher than the systemd init alternative so that
# ours is enabled instead.
ALTERNATIVE_PRIORITY[init] ?= "400"
+
+ALTERNATIVE:${PN} = "init"
+ALTERNATIVE_TARGET[init] = "${base_sbindir}/preinit-mounts"