summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb35
1 files changed, 16 insertions, 19 deletions
diff --git a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
index 77a2537698..54c5991d24 100644
--- a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
+++ b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
@@ -1,18 +1,28 @@
SUMMARY = "OpenBMC gdbus library"
DESCRIPTION = "libopenbmc_intf provides a set of gpio access \
methods and the GDBUS skeleton code for the org.openbmc DBUS API."
-PR = "r1"
+DEPENDS += "glib-2.0"
+DEPENDS += "cjson"
PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "file://gpio_defs.json"
+
+SKELETON_DIR = "libopenbmc_intf"
inherit skeleton
inherit pkgconfig
-DEPENDS += "glib-2.0"
-DEPENDS += "cjson"
-
-SKELETON_DIR = "libopenbmc_intf"
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ install -d ${D}${sysconfdir}/default/obmc/gpio/
+ install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
+}
-SRC_URI += "file://gpio_defs.json"
+# Ensure the library is not in the dev package
+FILES_SOLIBSDEV = ""
+# Now add the link to the production package
+FILES:${PN} += "${libdir}/libopenbmc_intf.so"
# Users of libopenbmc_intf use custom makefiles that do not
# support the proper library version detection and linking.
@@ -21,16 +31,3 @@ SRC_URI += "file://gpio_defs.json"
# This next line tells bitbake to skip the check which
# ensures no links are put in the rootfs
INSANE_SKIP:${PN} += "dev-so"
-
-# Ensure the library is not in the dev package
-FILES_SOLIBSDEV = ""
-
-# Now add the link to the production package
-FILES:${PN} += "${libdir}/libopenbmc_intf.so"
-
-do_install() {
- oe_runmake install DESTDIR=${D}
-
- install -d ${D}${sysconfdir}/default/obmc/gpio/
- install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
-}