summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support/boost/boost_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-support/boost/boost_%.bbappend')
-rw-r--r--meta-phosphor/recipes-support/boost/boost_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
new file mode 100644
index 0000000000..aa93d7305d
--- /dev/null
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -0,0 +1,12 @@
+#This is largely to improve our build times by not building or installing
+#modules that OpenBMC does not use by our coding standard. Another thing to
+#note is that for most targets, coroutine and context libraries are also added
+#with a BOOST_LIBS_append_<platform> for most targets. Chrono/Thread should not
+#be relied directly, but are required dependencies of context and coroutine.
+#See the relevant portion of the openbmc coding standard with regards to boost
+#libraries
+#
+#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
+#
+BOOST_LIBS_openbmc-phosphor = "chrono thread"
+