summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-x86
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-x86')
-rwxr-xr-xmeta-phosphor/recipes-x86/chassis/x86-power-control_git.bb13
-rw-r--r--meta-phosphor/recipes-x86/libpeci/libpeci_git.bb14
-rw-r--r--meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb13
3 files changed, 15 insertions, 25 deletions
diff --git a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
index f68629f920..52378e8bbe 100755
--- a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
+++ b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
@@ -1,15 +1,13 @@
SUMMARY = "Chassis Power Control service for Intel based platforms"
DESCRIPTION = "Chassis Power Control service for Intel based platforms"
-
-SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=https;branch=master"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRCREV = "8643c79740d21f4a21184de729c19f9aec0f7c48"
-
PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=https;branch=master"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+S = "${WORKDIR}/git"
inherit meson systemd pkgconfig
inherit obmc-phosphor-dbus-service
@@ -19,12 +17,9 @@ def get_service(d):
return "xyz.openbmc_project.Chassis.Control.Power@0.service"
else:
return " ".join(["xyz.openbmc_project.Chassis.Control.Power@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
-
SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
-
SYSTEMD_SERVICE:${PN} += "chassis-system-reset.service \
chassis-system-reset.target"
-
DEPENDS += " \
boost \
i2c-tools \
diff --git a/meta-phosphor/recipes-x86/libpeci/libpeci_git.bb b/meta-phosphor/recipes-x86/libpeci/libpeci_git.bb
index 78d40f08f1..a5033f7471 100644
--- a/meta-phosphor/recipes-x86/libpeci/libpeci_git.bb
+++ b/meta-phosphor/recipes-x86/libpeci/libpeci_git.bb
@@ -1,17 +1,15 @@
SUMMARY = "PECI Library"
DESCRIPTION = "PECI Library"
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
-inherit cmake pkgconfig systemd
+SRCREV = "58dac1fdb2c4656f151509be4105ea0be3ab1988"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[dbus-raw-peci] = "-DDBUS_RAW_PECI=ON,-DDBUS_RAW_PECI=OFF,boost sdbusplus"
+PV = "0.1+git${SRCPV}"
SRC_URI = "git://github.com/openbmc/libpeci;branch=master;protocol=https"
-PV = "0.1+git${SRCPV}"
-SRCREV = "58dac1fdb2c4656f151509be4105ea0be3ab1988"
-
S = "${WORKDIR}/git"
-
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[dbus-raw-peci] = "-DDBUS_RAW_PECI=ON,-DDBUS_RAW_PECI=OFF,boost sdbusplus"
SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'dbus-raw-peci', 'com.intel.peci.service', '', d)}"
+
+inherit cmake pkgconfig systemd
diff --git a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
index 19974e710f..c5fda1bdd5 100644
--- a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
+++ b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
@@ -1,20 +1,17 @@
SUMMARY = "PECI PCIe"
DESCRIPTION = "Gathers PCIe information using PECI \
and provides it on D-Bus"
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
-inherit cmake pkgconfig systemd
-
-SRC_URI = "git://github.com/openbmc/peci-pcie;branch=master;protocol=https"
-
DEPENDS = "boost sdbusplus libpeci"
-
-PV = "0.1+git${SRCPV}"
SRCREV = "be1fdbfddb8f753132e781109e72b5f2c64140a2"
+PV = "0.1+git${SRCPV}"
-S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/peci-pcie;branch=master;protocol=https"
+S = "${WORKDIR}/git"
SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.PCIe.service"
+inherit cmake pkgconfig systemd
+
EXTRA_OECMAKE = "-DYOCTO=1"