summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index 657123faa1..96453eff4d 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -278,6 +278,12 @@ do_deploy:append:raspberrypi3-64() {
echo "dtparam=audio=on" >> $CONFIG
}
+do_deploy:append() {
+ if grep -q -E '^.{80}.$' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt; then
+ bbwarn "config.txt contains lines longer than 80 characters, this is not supported"
+ fi
+}
+
addtask deploy before do_build after do_install
do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"