summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend')
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
index 9ce6425636..cdfe5bb8ba 100644
--- a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1 +1,15 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_rpi = " \
+ file://fw_env.config \
+"
+
+# special fix for raspberrypi-cm3
+SRC_URI_append_raspberrypi-cm3 = " file://0001-dm-core-Move-ofdata_to_platdata-call-earlier.patch"
+
DEPENDS_append_rpi = " u-boot-default-script"
+
+do_install_append_rpi () {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}