summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch')
-rw-r--r--meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch b/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch
new file mode 100644
index 0000000000..33480b12ce
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch
@@ -0,0 +1,28 @@
+From df5657d772accb275a12c1b1690befa8d87305c8 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 5 Mar 2022 09:53:41 -0800
+Subject: [PATCH] setup.py: Use setuptools instead of distutils
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 2b600ca..0fa0807 100644
+--- a/setup.py
++++ b/setup.py
+@@ -20,7 +20,7 @@ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+ """
+
+-from distutils.core import setup, Extension
++from setuptools import setup, Extension
+
+ classifiers = ['Development Status :: 5 - Production/Stable',
+ 'Operating System :: POSIX :: Linux',
+--
+2.35.1
+