summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-devtools/python')
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb6
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb2
9 files changed, 11 insertions, 11 deletions
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
index dc9e6802b3..4659ad9666 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
@@ -12,7 +12,7 @@ inherit setuptools3
DEPENDS += "python3-setuptools-scm-native"
-do_install_append() {
+do_install:append() {
# it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt
# 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only
if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then
@@ -20,11 +20,11 @@ do_install_append() {
fi
}
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
libgpiod \
python3-adafruit-platformdetect \
python3-adafruit-pureio \
python3-core \
"
-RDEPENDS_${PN}_append_rpi = " rpi-gpio"
+RDEPENDS:${PN}:append:rpi = " rpi-gpio"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb
index 7c1a26742e..7cccd5820b 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb
@@ -12,7 +12,7 @@ inherit setuptools3
DEPENDS += "python3-setuptools-scm-native"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3-adafruit-blinka \
python3-core \
"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
index b0475e6efd..c5da4ac611 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
@@ -12,7 +12,7 @@ inherit setuptools3
DEPENDS += "python3-setuptools-scm-native"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3-adafruit-blinka \
python3-core \
"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
index 12a63f3a59..eacca3edd7 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
@@ -12,7 +12,7 @@ inherit setuptools3
DEPENDS += "python3-setuptools-scm-native"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3-adafruit-blinka \
python3-adafruit-circuitpython-busdevice \
python3-adafruit-circuitpython-motor \
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb
index a46b13044c..23cd786c67 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb
@@ -12,7 +12,7 @@ inherit setuptools3
DEPENDS += "python3-setuptools-scm-native"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3-adafruit-blinka \
python3-adafruit-circuitpython-busdevice \
python3-adafruit-circuitpython-register \
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb
index 7d0377b49d..ccf5eaa646 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb
@@ -12,4 +12,4 @@ DEPENDS += "python3-setuptools-scm-native"
inherit setuptools3
-RDEPENDS_${PN} += "python3-core"
+RDEPENDS:${PN} += "python3-core"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
index 0574c532a5..b88affa090 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
@@ -12,4 +12,4 @@ inherit setuptools3
DEPENDS += "python3-setuptools-scm-native"
-RDEPENDS_${PN} += "python3-core"
+RDEPENDS:${PN} += "python3-core"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb
index a59e6f5738..63c7166a2b 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb
@@ -12,7 +12,7 @@ inherit setuptools3
DEPENDS += "python3-setuptools-scm-native"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3-core \
python3-ctypes \
python3-fcntl \
diff --git a/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb b/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb
index d5653cb0db..1c8075f3e2 100644
--- a/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb
+++ b/meta-raspberrypi/recipes-devtools/python/rpio_0.10.0.bb
@@ -14,7 +14,7 @@ inherit setuptools3
COMPATIBLE_MACHINE = "^rpi$"
-RDEPENDS_${PN} = "\
+RDEPENDS:${PN} = "\
python3-logging \
python3-threading \
"