summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-graphics/wayland/weston-init.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-graphics/wayland/weston-init.bbappend')
-rw-r--r--meta-raspberrypi/recipes-graphics/wayland/weston-init.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-graphics/wayland/weston-init.bbappend b/meta-raspberrypi/recipes-graphics/wayland/weston-init.bbappend
new file mode 100644
index 0000000000..b6d6f2e8a7
--- /dev/null
+++ b/meta-raspberrypi/recipes-graphics/wayland/weston-init.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+do_install:append:rpi() {
+ if [ -e ${D}/${sysconfdir}/init.d/weston ]; then
+ sed -i 's#weston-start --#weston-start -- --continue-without-input#' ${D}/${sysconfdir}/init.d/weston
+ fi
+ if [ -e ${D}${systemd_system_unitdir}/weston.service ]; then
+ sed -i 's#ExecStart=/usr/bin/weston#ExecStart=/usr/bin/weston --continue-without-input#' ${D}${systemd_system_unitdir}/weston.service
+ fi
+}