summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-core/fts/fts.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-core/fts/fts.bb')
-rw-r--r--poky/meta/recipes-core/fts/fts.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/poky/meta/recipes-core/fts/fts.bb b/poky/meta/recipes-core/fts/fts.bb
new file mode 100644
index 0000000000..02f54086a3
--- /dev/null
+++ b/poky/meta/recipes-core/fts/fts.bb
@@ -0,0 +1,22 @@
+# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "POSIX file tree stream operations library"
+HOMEPAGE = "https://sites.google.com/a/bostic.com/keithbostic"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5ffe358174aad383f1b69ce3b53da982"
+SECTION = "libs"
+
+SRCREV = "944333aed9dc24cfa76cc64bfe70c75d25652753"
+PV = "1.2+git${SRCPV}"
+
+SRC_URI = "git://github.com/voidlinux/musl-fts \
+"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+#
+# We will skip parsing for non-musl systems
+#
+COMPATIBLE_HOST = ".*-musl.*"
+