summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-core/volatile-binds/volatile-binds.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-core/volatile-binds/volatile-binds.bb')
-rw-r--r--poky/meta/recipes-core/volatile-binds/volatile-binds.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/poky/meta/recipes-core/volatile-binds/volatile-binds.bb b/poky/meta/recipes-core/volatile-binds/volatile-binds.bb
index d5c5538cd7..3fefa9abde 100644
--- a/poky/meta/recipes-core/volatile-binds/volatile-binds.bb
+++ b/poky/meta/recipes-core/volatile-binds/volatile-binds.bb
@@ -37,6 +37,9 @@ SYSTEMD_SERVICE:${PN} = "${@volatile_systemd_services(d)}"
FILES:${PN} += "${systemd_system_unitdir}/*.service ${servicedir}"
+# Set to 1 to forcibly skip OverlayFS, and default to copy+bind
+AVOID_OVERLAYFS = "0"
+
do_compile () {
while read spec mountpoint; do
if [ -z "$spec" ]; then
@@ -47,6 +50,7 @@ do_compile () {
servicefile="$(echo "$servicefile" | tr / -).service"
sed -e "s#@what@#$spec#g; s#@where@#$mountpoint#g" \
-e "s#@whatparent@#${spec%/*}#g; s#@whereparent@#${mountpoint%/*}#g" \
+ -e "s#@avoid_overlayfs@#${@d.getVar('AVOID_OVERLAYFS')}#g" \
volatile-binds.service.in >$servicefile
done <<END
${@d.getVar('VOLATILE_BINDS').replace("\\n", "\n")}