summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/ccache/ccache_4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/ccache/ccache_4.8.bb')
-rw-r--r--poky/meta/recipes-devtools/ccache/ccache_4.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/ccache/ccache_4.8.bb b/poky/meta/recipes-devtools/ccache/ccache_4.8.bb
new file mode 100644
index 0000000000..6cad0dd7c6
--- /dev/null
+++ b/poky/meta/recipes-devtools/ccache/ccache_4.8.bb
@@ -0,0 +1,26 @@
+SUMMARY = "a fast C/C++ compiler cache"
+DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
+by caching the result of previous compilations and detecting when the \
+same compilation is being done again. Supported languages are C, C\+\+, \
+Objective-C and Objective-C++."
+HOMEPAGE = "http://ccache.samba.org"
+SECTION = "devel"
+
+LICENSE = "GPL-3.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=43a02b74c9eb73a0b978ae5082f5f1b6"
+
+DEPENDS = "zstd"
+
+SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
+ file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
+ "
+SRC_URI[sha256sum] = "ac4b01748fd59cfe07e070c34432b91bdd0fd8640e1e653a80b01d6a523186b0"
+
+inherit cmake github-releases
+
+PATCHTOOL = "patch"
+
+BBCLASSEXTEND = "native nativesdk"
+
+PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
+PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"