summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python-native_2.7.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python-native_2.7.15.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python-native_2.7.15.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/poky/meta/recipes-devtools/python/python-native_2.7.15.bb b/poky/meta/recipes-devtools/python/python-native_2.7.15.bb
index 7c491fa3e0..de35104c60 100644
--- a/poky/meta/recipes-devtools/python/python-native_2.7.15.bb
+++ b/poky/meta/recipes-devtools/python/python-native_2.7.15.bb
@@ -69,7 +69,11 @@ python(){
import json
pythondir = d.getVar('THISDIR',True)
with open(pythondir+'/python/python2-manifest.json') as manifest_file:
- python_manifest=json.load(manifest_file)
+ manifest_str = manifest_file.read()
+ json_start = manifest_str.find('# EOC') + 6
+ manifest_file.seek(json_start)
+ manifest_str = manifest_file.read()
+ python_manifest = json.loads(manifest_str)
rprovides = d.getVar('RPROVIDES').split()