summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-dbusmock_0.22.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-dbusmock_0.22.0.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-dbusmock_0.22.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-dbusmock_0.22.0.bb b/poky/meta/recipes-devtools/python/python3-dbusmock_0.22.0.bb
new file mode 100644
index 0000000000..b1feee8416
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-dbusmock_0.22.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
+
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI[sha256sum] = "2191919cc411fb94953b36e46bfd55ee5ad4162432ee0d0892bc2c4770ff5d7c"
+
+PYPI_PACKAGE = "python-dbusmock"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-dbus \
+ ${PYTHON_PN}-pygobject \
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-xml \
+ "