summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-dbusmock_0.28.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-dbusmock_0.28.4.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-dbusmock_0.28.4.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-dbusmock_0.28.4.bb b/poky/meta/recipes-devtools/python/python3-dbusmock_0.28.4.bb
new file mode 100644
index 0000000000..e895d87b7b
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-dbusmock_0.28.4.bb
@@ -0,0 +1,18 @@
+SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
+HOMEPAGE = "https://pypi.org/project/python-dbusmock/"
+
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI[sha256sum] = "52ad024a44d46602084fd91c0c467ab95b7ecf27c4e2168e0d2160623f18c0a2"
+
+PYPI_PACKAGE = "python-dbusmock"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-dbus \
+ ${PYTHON_PN}-pygobject \
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-xml \
+ "