summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb b/poky/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
index 8d107384a6..fe6b16ac54 100644
--- a/poky/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
+++ b/poky/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
@@ -13,13 +13,17 @@ SRC_URI[sha256sum] = "3c9bd9c140515bfe62dd938c6610d10d6efb9e35cc647fc614fe5fb3a5
inherit pypi python_flit_core
# Need to install by hand as there's a dependency loop
-DEPENDS:remove:class-native = " python3-installer-native"
+DEPENDS:remove:class-native = " python3-picobuild-native python3-installer-native"
DEPENDS:append:class-native = " unzip-native"
# We need the full flit tarball
PYPI_PACKAGE = "flit"
PEP517_SOURCE_PATH = "${S}/flit_core"
+do_compile:class-native () {
+ python_flit_core_do_manual_build
+}
+
do_install:class-native () {
python_pep517_do_bootstrap_install
}