summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-installer_0.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-installer_0.7.0.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-installer_0.7.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-installer_0.7.0.bb b/poky/meta/recipes-devtools/python/python3-installer_0.7.0.bb
index d7f1e79a5c..9429705b1f 100644
--- a/poky/meta/recipes-devtools/python/python3-installer_0.7.0.bb
+++ b/poky/meta/recipes-devtools/python/python3-installer_0.7.0.bb
@@ -15,6 +15,12 @@ inherit pypi python_flit_core
# Bootstrap the native build
DEPENDS:remove:class-native = "python3-build-native python3-installer-native"
+RDEPENDS:${PN} += " \
+ python3-compile \
+ python3-compression \
+ python3-netclient \
+"
+
INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
do_compile:class-native () {