summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-packaging_20.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-packaging_20.9.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-packaging_20.9.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-packaging_20.9.bb b/poky/meta/recipes-devtools/python/python3-packaging_20.9.bb
new file mode 100644
index 0000000000..92cf6a25fe
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-packaging_20.9.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Core utilities for Python packages"
+HOMEPAGE = "https://github.com/pypa/packaging"
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
+
+SRC_URI[sha256sum] = "5b327ac1320dc863dca72f4514ecc086f31186744b84a230374cc1fd776feae5"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"