summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-pip_22.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-pip_22.0.3.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-pip_22.0.3.bb43
1 files changed, 6 insertions, 37 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-pip_22.0.3.bb b/poky/meta/recipes-devtools/python/python3-pip_22.0.3.bb
index 7eb9fb69ba..ee3e578b2c 100644
--- a/poky/meta/recipes-devtools/python/python3-pip_22.0.3.bb
+++ b/poky/meta/recipes-devtools/python/python3-pip_22.0.3.bb
@@ -4,13 +4,7 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=63ec52baf95163b597008bb46db68030"
-inherit pypi setuptools_build_meta
-
-DEPENDS += "python3 python3-setuptools-native"
-
-# To avoid a dependency loop; we bootstrap -native
-DEPENDS:remove:class-native = "python3-pip-native"
-DEPENDS:append:class-native = " unzip-native"
+inherit pypi python_setuptools_build_meta
SRC_URI += "file://0001-change-shebang-to-python3.patch"
SRC_URI += "file://no_shebang_mangling.patch"
@@ -18,37 +12,8 @@ SRC_URI += "file://reproducible.patch"
SRC_URI[sha256sum] = "f29d589df8c8ab99c060e68ad294c4a9ed896624f6368c5349d70aa581b333d0"
-PYPA_WHEEL ?= "${B}/dist/${PYPI_PACKAGE}-${PV}-*.whl"
-
-do_install:class-native() {
- # Bootstrap to prevent dependency loop in python3-pip-native
- install -d ${D}${PYTHON_SITEPACKAGES_DIR}
- unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PYPA_WHEEL} || \
- bbfatal_log "Failed to unzip wheel: ${PYPA_WHEEL}. Check the logs."
-
- # pip install would normally generate [console_scripts] in ${bindir}
- install -d ${D}/${bindir}
- # We will skip the ${bindir}/pip variant as we would just remove it in the do_install:append
- cat << EOF >> ${D}/${bindir}/pip3 | tee ${D}/${bindir}/pip${PYTHON_BASEVERSION}
-#!/bin/sh
-'''exec' ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} "\$0" "\$@"
-' '''
-# -*- coding: utf-8 -*-
-import re
-import sys
-from pip._internal.cli.main import main
-if __name__ == '__main__':
- sys.argv[0] = re.sub(r'(-script\.pyw|\.exe)?$', '', sys.argv[0])
- sys.exit(main())
-EOF
- chmod 0755 ${D}${bindir}/pip3 ${D}${bindir}/pip${PYTHON_BASEVERSION}
-}
-
do_install:append() {
- # Install as pip3 and leave pip2 as default
- if [ -e ${D}/${bindir}/pip ]; then
- rm ${D}/${bindir}/pip
- fi
+ rm -f ${D}/${bindir}/pip
}
RDEPENDS:${PN} = "\
@@ -65,3 +30,7 @@ RDEPENDS:${PN} = "\
"
BBCLASSEXTEND = "native nativesdk"
+
+# This used to use the bootstrap install which didn't compile. Until we bump the
+# tmpdir version we can't compile the native otherwise the sysroot unpack fails
+INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"