summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-psutil_5.9.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-psutil_5.9.7.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-psutil_5.9.7.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-psutil_5.9.7.bb b/poky/meta/recipes-devtools/python/python3-psutil_5.9.7.bb
new file mode 100644
index 0000000000..9a8c3e11f8
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-psutil_5.9.7.bb
@@ -0,0 +1,41 @@
+SUMMARY = "A cross-platform process and system utilities module for Python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a9c72113a843d0d732a0ac1c200d81b1"
+HOMEPAGE = "https://pypi.org/project/psutil/"
+
+SRC_URI[sha256sum] = "3f02134e82cfb5d089fddf20bb2e03fd5cd52395321d1c8458a9e58500ff417c"
+
+inherit pypi setuptools3
+
+PACKAGES =+ "${PN}-tests"
+
+FILES:${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
+"
+
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-resource \
+"
+
+RDEPENDS:${PN}-tests += " \
+ ${PN} \
+ ${PYTHON_PN} \
+ coreutils \
+ procps \
+ binutils \
+ gcc \
+ gcc-symlinks \
+ libstdc++ \
+ libstdc++-dev \
+"
+
+INSANE_SKIP:${PN}-tests += "dev-deps"
+
+BBCLASSEXTEND = "native"