summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb b/poky/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
index 6f7d9a09ec..797a7cec8b 100644
--- a/poky/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
+++ b/poky/meta/recipes-devtools/python/python3-pygobject_3.44.1.bb
@@ -8,9 +8,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
GNOMEBASEBUILDCLASS = "meson"
GIR_MESON_OPTION = ""
-inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even features_check
+inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even
-REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+python() {
+ if d.getVar('CLASSOVERRIDE') == "class-target" and not bb.utils.to_boolean(d.getVar("GI_DATA_ENABLED")):
+ raise bb.parse.SkipRecipe("GI not available")
+}
DEPENDS += "python3 glib-2.0"