summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb b/poky/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
index 502967fd20..01e29cc6d8 100644
--- a/poky/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
+++ b/poky/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
@@ -18,13 +18,16 @@ inherit cargo pypi python_setuptools_build_meta
DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
-RDEPENDS:${PN}:class-native += " \
- python3-semantic-version-native \
- python3-setuptools-native \
- python3-setuptools-scm-native \
- python3-toml-native \
- python3-typing-extensions-native \
- python3-wheel-native \
+RDEPENDS:${PN} += " \
+ python3-distutils \
+ python3-json \
+ python3-semantic-version \
+ python3-setuptools \
+ python3-setuptools-scm \
+ python3-shell \
+ python3-toml \
+ python3-typing-extensions \
+ python3-wheel \
"
BBCLASSEXTEND = "native"