summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-zipp_3.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-zipp_3.8.0.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-zipp_3.8.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-zipp_3.8.0.bb b/poky/meta/recipes-devtools/python/python3-zipp_3.8.0.bb
new file mode 100644
index 0000000000..f1fd383842
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-zipp_3.8.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE = "https://github.com/jaraco/zipp"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
+
+SRC_URI[sha256sum] = "56bf8aadb83c24db6c4b577e13de374ccfb67da2078beba1d037c17980bf43ad"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += "${PYTHON_PN}-toml-native"
+
+RDEPENDS:${PN} += "${PYTHON_PN}-compression \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-more-itertools"
+
+BBCLASSEXTEND = "native nativesdk"