summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/rust/cargo-c-native_0.9.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/rust/cargo-c-native_0.9.18.bb')
-rw-r--r--poky/meta/recipes-devtools/rust/cargo-c-native_0.9.18.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/rust/cargo-c-native_0.9.18.bb b/poky/meta/recipes-devtools/rust/cargo-c-native_0.9.18.bb
new file mode 100644
index 0000000000..4f34f50ca9
--- /dev/null
+++ b/poky/meta/recipes-devtools/rust/cargo-c-native_0.9.18.bb
@@ -0,0 +1,23 @@
+SUMMARY = "cargo applet to build and install C-ABI compatible dynamic and static libraries."
+HOMEPAGE = "https://crates.io/crates/cargo-c"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE;md5=384ed0e2e0b2dac094e51fbf93fdcbe0 \
+"
+
+PR = "r1"
+
+SRC_URI = " \
+ git://github.com/lu-zero/cargo-c.git;branch=master;protocol=https \
+ file://0001-Add-Cargo.lock-file.patch \
+"
+
+SRCREV = "4eaf39ebbbc9ab8f092adf487d5b53435511d619"
+S = "${WORKDIR}/git"
+
+inherit cargo cargo-update-recipe-crates pkgconfig native
+
+DEPENDS = "openssl curl"
+
+require ${BPN}-crates.inc
+