summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-rt/images/core-image-rt.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-rt/images/core-image-rt.bb')
-rw-r--r--poky/meta/recipes-rt/images/core-image-rt.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/poky/meta/recipes-rt/images/core-image-rt.bb b/poky/meta/recipes-rt/images/core-image-rt.bb
new file mode 100644
index 0000000000..9cb93b3de5
--- /dev/null
+++ b/poky/meta/recipes-rt/images/core-image-rt.bb
@@ -0,0 +1,17 @@
+require recipes-core/images/core-image-minimal.bb
+
+# Skip processing of this recipe if linux-yocto-rt is not explicitly specified as the
+# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
+# to build multiple virtual/kernel providers.
+python () {
+ if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
+ raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
+}
+
+DESCRIPTION = "A small image just capable of allowing a device to boot plus a \
+real-time test suite and tools appropriate for real-time use."
+DEPENDS = "linux-yocto-rt"
+
+IMAGE_INSTALL += "rt-tests hwlatdetect"
+
+LICENSE = "MIT"